Flutter2へアップグレード後発生。 AndoirdのminSdkVersionを上げたことで発生したのだろうか? ``` W/Firestore( 3704): (23.0.3) [GrpcCallProvider]: Failed to update ssl context: com.google.android.gms.common.GooglePlayServicesNotAvailableException The Flutter DevTools debugger and profiler on Android SDK built for x86 is available at: ... E/AndroidRuntime( 3704): FATAL EXCEPTION: grpc-okhttp-0 E/AndroidRuntime( 3704): Process: com.example.app, PID: 3777 E/AndroidRuntime( 3704): java.lang.AssertionError: Method getAlpnSelectedProtocol not supported for object SSL socket over Socket[address=firestore.googleapis.com/142.250.207.42,port=443,localPort=60650] ... ``` [ここ](https://stackoverflow.com/questions/64668851/why-the-firestore-isnt-working-on-android-studio)にあるように、必要な依存関係が足りていないので`android/app/build.gradle`のdependenciesに以下を追加する。 ``` implementation "io.grpc:grpc-okhttp:1.32.2" ```
2021/11/18 16:09:27

コメント (0)

あなたもコメントしてみませんか

アカウント新規作成(無料)

既にアカウントを持っている方は ログイン